0

I have disabled the access permissions of my SiteCollection, but the option to share still appear for people who have no rights to see it. Is not supposed to disappear for users who have no rights?

enter image description here

Partilhar = Share

1

Per my knowledge, to disable "Share button" in SharePoint, simply disable access requests:

  1. Go to Site settings page of your SharePoint site.

  2. Click on "Site Permissions" link under "Users and Permissions" group.

  3. Click on "Access Request Settings" in the ribbon.

  4. Uncheck "Allow access request" and click on "Ok" to save your changes.

enter image description here

Remember, Share button will still be visible for Site owners and administrators!

  • Hello, the problem is exactly this. I have the access requests disabled and the button still appears for users who are not supposed to see it. – CSAnimor Mar 27 '19 at 16:19
  • Test if they can share by clicking the share button(or they will see access deny error when clicking this button). – imp. MSFT Mar 28 '19 at 1:23
  • Yes, appears the pop up to invite people or to share with someone. – CSAnimor Apr 2 '19 at 14:19
  • Hello, I contacted Microsoft and they said that the share button can still appear but it won't let the user, who has no permissions, to share. Will give an error message to them. – CSAnimor Apr 11 '19 at 9:46
  • In the screenshot, you still have "Allow members to share" and "Allow members to invite others to the site members group" checked. Depending on the scenario, you'd probably want to uncheck those too. – Thriggle Feb 4 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.