0

I've got a list on my site that I'm trying to query via REST:

https://mysite/sites/division/office/program/subprogram/_api/web/lists/getbytitle('Taskers')/items

I can confirm the list exists, and I have checked that the title is correct.I have tried changing the query to query by GUID instead of title, and I still get the same error. There are no calculated columns in the list. I can query other lists in the same site and return results successfully. Any ideas of what I should look for to troubleshoot this problem further? I will add that this site was recently migrated from SP 2010 to SP Online.

  • 1
    Try to add $select=Title and check if it work. – Sergei Sergeev Mar 25 at 17:32
1

Try to access the URL below to check if it works.

https://mysite/sites/division/office/program/subprogram/_api/web/lists

And check if you can find the "Taskers" list in the results.

If still not works, we can use Fiddler to send a request and check the responses.

  • That did it- why it worked without it on other lists and not on this one is a mystery to me, but making sure to add the parameters after /items solved it! – Scott Davis Mar 27 at 17:58
0

Sounds like you may have a throttling issue. Does the list have more than 5000 items? If so, try to index a column.

List Settings --> Indexed Columns --> Create a new index --> select a column (even Title) --> OK

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.