0

I have created a custom column of the type "Choice" and then a view which will sort by that column. Surprisingly, one folder always gets sorted last and not with its "siblings" which have the same value entered for that column.

Misordered folders

As you see, the last folder, whose name starts with "Om", should be up on top with the others of type "Planet".

This only happens when I open the view. When I sort the column manually, the sorting works as expected. You can see that the "Om" folder has moved up as the last of the planets, even though it is still sorted after the "Si" folder (so not alphabetically).

manually ordered

All folders here are from the same custom type, which allows me to assign the "Usage directions" and "Celestial body" columns, but are else all normal. The properties of the "Om" folder look just like the properties of any other folder shown here.

The sorting settings for this view are below. The "IsPinned" property is set to "No" for all folders here, including the misbehaving "Om" folder. The problem also persists if I check the "Sort only by specified criteria" box.

sorting settings

What is wrong with this sorting, and how do I get it to behave normally?

  • 1
    What happens if you remove the IsPinned sorting, and just have it sort by Celestial Body? Is there a different behaviour? – KGlasier Mar 25 at 14:03
1

I found what was happening here.

This being an initial filling of this Sharepoint instance, I had not yet planned everything I wanted from the beginning. So, at first I created some folders, afterwards I noticed that I want a pinning funciton and added the IsPinned field, and afterwards made some new folders.

I set the default for IsPinned to be FALSE, and the checkbox on the UI appears as empty for all folders unless I set it. But it seems that, for the old folders (created before the field existed), it must have some kind of null value instead of FALSE. The UI of the checkbox shows no difference, but the sorting of the folders is consistent with this interpretation. Also, when I go to a missorted old folder, set IsPinned to TRUE, save, then set it to FALSE and save again, it is afterwards sorted properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.