0

I did a database backup from SP 2010 and restored it to SP 2013 Mount-SPContentDatabase followed by site upgrade. Everything looks good except the users did not get converted in claims based. (I can not change my source web application to claim based). users in the groups aren't able to see and perform task and most of these groups have various contribute access. What are my options? SO CRITICAL.

0

You need to run Convert-SPWebApplication -Identity http://webAppUrl -From Legacy -To Claims -RetainPermissions:$true.

You will want to do that each time you mount a content database to the claims-enabled web Application.

Convert-SPWebApplication

| improve this answer | |
  • Thanks Trevor. Let me give it a try – Ruby Trustit Mar 19 '19 at 16:18
  • I ran the command against the site's web app and mysite as well. nothing happened. When i click on a name it stills shows domain\username in the url . The other 2013 regular site (not from backup/restore) shows up as /Person.aspx?accountname=i:0#.w|colgate\dtden01 – Ruby Trustit Mar 19 '19 at 16:33
  • I can re-run it with -Force parameter and what happens. I wonder if I have to do this for both the site collection web app and mysite web app – Ruby Trustit Mar 19 '19 at 16:43
  • 1
    I got it to work using farm account . Thanks Trevor – Ruby Trustit Mar 19 '19 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.