0

I am trying to add a Web Front End server to SharePoint 2010 farm. This server was already configured with farm but due to some reasons we have to reconfigure it with farm. I am running SharePoint Products Configuration Wizard but this error comes "Failed to connect to the configuration database."

Below is the stack trace from logs file.

Failed to connect to the configuration database. An exception of type System.Xml.XmlException was thrown. Additional exception information: 'True' is an unexpected token. Expecting white space. Line 1, position 7504. System.Xml.XmlException: 'True' is an unexpected token. Expecting white space. Line 1, position 7504. at System.Xml.XmlTextReaderImpl.Throw(Exception e) at System.Xml.XmlTextReaderImpl.ParseAttributes() at System.Xml.XmlTextReaderImpl.ParseElement() at System.Xml.XmlTextReaderImpl.ParseDocumentContent() at System.Xml.XmlLoader.ParsePartialContent(XmlNode parentNode, String innerxmltext, XmlNodeType nt) at System.Xml.XmlLoader.LoadInnerXmlElement(XmlElement node, String innerxmltext) at Microsoft.SharePoint.Administration.SPWebConfigFileChanges.ApplyModificationsWebConfigXmlDocument(XmlDocument xdWebConfig, String filepath) at Microsoft.SharePoint.Administration.SPWebApplication.ApplyWebConfigModifications() at Microsoft.SharePoint.Administration.SPWebApplication.Provision() at Microsoft.SharePoint.Administration.SPWebServiceInstance.Provision() at Microsoft.SharePoint.Administration.SPFarm.Join() at Microsoft.SharePoint.PostSetupConfiguration.ConfigurationDatabaseTask.CreateOrConnectConfigDb() at Microsoft.SharePoint.PostSetupConfiguration.ConfigurationDatabaseTask.Run() at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

0

You need to troubleshoot the connectivity to the DB server. You can do that quickly with UDL tester. Create and text file and change its extension to udl. That will turn it into simple client where you can test connecting to DB.

You should review as well logs from DB as they may point out to the issue.

Main factors to check. 1. Under what account you execute the PSConfig (I always use SPInstall service account that was used to install SQL and SHarepoint initially) 2.Do you get any transmission issues (like mismatch between security protocols SSL vs TLS). SOme of those issues my sufrace in CAPI2 logs (under windows log in event viewer)

  • Thanks for your suggestions. I have also tried with service install account but same error appears. When i run udl test file i got error "[DBNETLIB][ConnectionOpen (SECCreateCredentails()).] SSL Security error". TLS 1.2 is enabled on QA and WEB server. – Zahid Hamid Mar 14 at 13:30
  • ok so your issue is with establishing SSL connection. Review the CAPI2 logs on the DB server it may point to the problem you are having. maybe the TLS is not properly set up on the new server. – Marek Sarad Mar 14 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.