1

I have recently modified a list in SharePoint Online that was using the modern experience, but has now reverted to the classic experience for other users except myself. Users are unable to revert back to modern experience. I have checked the following:

  • When users click 'Exit classic experience', the list view refreshes but remains in classic experience
  • All views in the list appear as classic experience
  • Users are able to use modern experience in other lists in the same site
  • I have checked that there are no list features which would force the classic view to appear
  • I have deleted and recreated views to no avail
  • I have checked the Modern experience is set as the default in the list's advanced settings
  • As a Site Collection Administrator I can see the modern experience in the affected list
  • Users have tried force-refreshing, clearing internet browser cache/cookies and clearing Web Server Extensions cache to no avail
  • Possibly connected is that users cannot save items; when they try to do so they get an error saying 'The server was unable to process the request'

It is also worth mentioning that this started to happen after I made changes to a workflow connected to the list and some of the list's columns. Could this have 'broken' the list in any way? Or made a change that needs to be 'published' by me ?

  • You say workflow, what kind of wf is it classic WF or FLOW? – Marek Sarad Mar 12 at 10:53
  • @MarekSarad It is a classic workflow, as a SharePoint 2013 Workflow created in SharePoint Designer 2013. Thanks. – KyokoHunter Mar 12 at 16:02
0

I managed to resolve this issue by ensuring the users had permissions to the parent Site of the list. It transpired that the affected users had been incorrectly removed from the parent Site by another admin, but still had permissions to the list as the list has unique permissions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.