I have recently taken over management of my law office's sharepoint online account. I am far from an expert in this field but unfortunately I'm all they've got.

Our sharepoint account was created by a coworker who is no longer with us. He set up one tenant site thebigcheese.sharepoint.com (obviously not our real tenant). When you go to that tenant address, it redirects you to a page thebigcheese.sharepoint.com/sitepages/home.aspx where you can view a list of all of our office's legal clients.

When you click on the clients name, you are directed to a team site for that client (e.g. thebigcheese.sharepoint.com/sites/cheddar ; thebigcheese.sharepoint.com/sites/gouda ; The bigcheese.sharepoint.com/sites/velveeta) There are about 250 team sites

My problem is that when my predecessor set this up, he left the default permissions in place, so every member of my office can add and delete documents and delete versions. This is really not ideal. I would like to make it so the administrator is the only person who can delete, and the rest of the office can create and edit files, but can't delete. Is there a way to make a change that would apply globally across all 250 team sites or do I need to go in and change the permissions 250 times (that would really be a bummer).

Thanks for your help.

1 Answer 1


Option 1: Do it through Central Admin.


  1. Go to your Central Admin site (use farm/admin account)
  2. Select Manage web application under Application Management
  3. Click the desired web application (to highlight)
  4. From the ribbon, click on User Permission
  5. Check permissions as deemed necessary

Option 2: Do it from the top level site.


  1. From your site, click on the Gear Icon on the top right
  2. Select Site Settings
  3. Click Go to top level site on the bottom right (this only appears if you're not on the top level; situational step)
  4. Click Site Permission
  5. From the ribbon, select Permission Levels
  6. Either Add a Permission Level or Edit the existing by clicking them

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.