0

Environment: SharePoint 2013 On premises

We are having SharePoint 2013 server with load balancing, and we have an DNS name for the load balancing. While we open the Central Administration page or SharePoint site with the DNS name (http://DNSname:portnumber/default.aspx), the page is not opening . But when we open with servername(http://servername:portnumber/default.aspx) it is opening.

Kindly suggest on how to get it resolve the problem.

1

DNS record should be used without port number.

  1. In Central Administration, under Application Management > Configure alternate access mappings > select Central Administration WA > make sure you Public Url (for intranet) which is http://centraladmin.company.com set here
  2. Look at server where the CA is running to IIS and to bindings for CA site. Make sure you have here same URL: http://centraladmin.company.com
  3. Check DNS record pointing to the NLB (or APP CA server), that you have correct URL address http://centraladmin.company.com
  4. Check settings of NLB that its pointing to correct server.

PS: I dont understand why you have CA on NLB, cause CA can run only once per Farm.

Hope it helps!

  • Re. CA you can actually run it on multiple servers - seen that config couple of times in risk averse industry. REF: social.technet.microsoft.com/Forums/sharepoint/en-US/… – Marek Sarad Mar 8 at 10:46
  • yes but" Although you can install central admin on multiple servers there is only one default that can be used at one time. " there is ONLY ONE DEFAULT, I meant this.. – Zdeněk Vinduška Mar 8 at 12:24
  • Well Spencer Harbar disagrees with you. Trick is updating the registry entries on the servers. harbar.net/articles/spca.aspx . A lot of Defense and Life Sciences companies employ this model. – Marek Sarad Mar 8 at 13:38
  • yea maybe, but if you will have more CA on different ports I think you cannot use AAM for this or if yes I dont know how, you should probably configure something on NLB or IIS on each server as redirect? – Zdeněk Vinduška Mar 8 at 13:42
  • In the example from Spencer they are running on same port. This article goes into details as there are some different cases when you are using Kerberos. From what I remember the limitation of this approach is that you can run CA on 2 servers no more. These days i struck down such request with argumentation that we do SP administration through PowerShell not CA and we can run PS on any server in the farm. – Marek Sarad Mar 8 at 13:49
0

you may need to register http://DNSname into Alternate Access Mapping on Central Administration. refer to this

  • Hi, In the SharePoint server any site URL (central admin URL or other site collection URL's) not opening with the DNS name. But sites are opening with server name. – user399731 Mar 8 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.