0

Firstly, I'd like to point out that this seems to be related to the security issue from October 2018. This issue caused workflows to not be able to be published with the following error "Type System.CodeDom.CodeBinaryOperatorExpression is not marked as authorized in the application configuration file"

We fixed the issue and everything worked fine... until now

We created a new url that redirects to the old one through IIS.

If you use the old url and start a workflow, it works just as intended. If you edit the workflow by connecting to the site collection using the old url it works just fine.

However if you use the new url and start a workflow you get the errors "failed on start" "workflow cancelled by system account" If you try to publish the workflow by connecting to the site collection using the new url you get the same errors that came with the October security update.

One last thing to note, the new url is on a different port from the old one. The url is redirected through IIS and not the alternate access mappings.

We want the users to use the new url but with this workflow issue they are forced to stay on the old one....

I believe that if we can publish the workflows through the new url, then the users could run the workflows through the new url as well. How can I go about fixing it? is there some setting in IIS that might be affecting it? Or is it a webconfig setting instead?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.