1
  • This is a test SharePoint 2019 MinRole farm with 2 servers (1 App with Search, 2 Front-End with Distributed Cache).

  • In Central Administration I see the yellow warning under Index Partition 0 since it was set up.

  • When running Get-SPEnterpriseSearchStatus -SearchApplication $ssa |ft -Autosize Name, State, Details IndexComponent State shows Degraded.

  • If I change the Windows Service SearchHostController Service Account in Central Admin from the "services" account to the "farm" account, this issue will get fixed.

  • I have checked all permissions to make sure they are correct.

Any idea about how to resolve this issue with the account used to run SearchHostController?

11
  • 1
    Services account need to have policy rights: "Run as Service", has it ? You can try to add this account to Server Administrators, if it works too, if yes, there will be only some rights problem. Try it please Commented Mar 7, 2019 at 13:39
  • @ZdeněkVinduška Added "services" account to the Server Administrators and State changed from Degraded to Active. As I can not leave this account in the admin group, I need to find out what permission it is missing so it can work properly for the IndexComponent as for the other components. Any ideas?Thank you very much.
    – MLC
    Commented Mar 7, 2019 at 20:22
  • 1
    policy right - Run As Service - for windows service of search, add this account as Admininstartor - Go to CA > Service Applications > Select Search Service Application > in ribbon Permission > add account with full control Commented Mar 7, 2019 at 22:25
  • 1- "services" account already had "Log on as a service" in the server's Local Security Policy. 2- Added "services" with Full Control under Permissions in Search Service Application 3- removed the account from the Server's administrator group in Active Directory.
    – MLC
    Commented Mar 8, 2019 at 20:21
  • I added answer, you can mark it as correct :) your will be probably deleted cause it "thank youL answer Commented Mar 8, 2019 at 20:38

2 Answers 2

2
  1. policy right - Run As Service - for windows service of search
  2. add this account as Admininstartor - Go to CA > Service Applications > Select Search Service Application > in ribbon Permission > add account with full control

Hope it helps!

0

Assigning Modify permissions for the "services" account at the folder level on the server on D:\SearchIndex (where the index partition is located) fixed the Degraded State.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.