I have a list with a workflow customized using SharePoint Designer. It's on the SP2016 platform.

If I am inside the Application (APP) server, I load the site, and I create a list item, the workflow successfully starts and completes, and sends email notifications.

If I am using a normal user machine or the Web Front End (WFE) server, I load the site, and I create a list item, the workflow successfully starts and completes, but does not send email notifications. In the workflow history, you will see the error "The e-mail message cannot be sent. Make sure the outgoing e-mail settings for the server are configured correctly".

Inside the server, the antivirus does not have blocking rules for emails.

I cannot find anything useful in the SharePoint logs. We're currently requesting for Event Viewer and IIS logs.

Note that subscribing to SharePoint alerts are working whether the SharePoint alert was triggered from inside or outside of the server (Example: I subscribed to all events on a list. Whether I create a list item from inside or outside of the server, I still get a SharePoint alert).

Any ideas on what to look for or how to further troubleshoot?

Advanced thanks!

2 Answers 2


You can try making sure that the "Workflow can use app permissions" feature is activated and try wrapping the send email action within an app step.

A detailed guide is available here from Microsoft. It even demostrates the send email action.


After my colleague checked again the SharePoint logs, the issue was really email related (filter by Category = "E-Mail"). enter image description here

The issue was fixed when my colleague set the outgoing email settings to the host name of the application server that hosts the SMTP service. Then in the virtual SMTP server's settings > Advanced Delivery > Smart host, he set it to the SMTP relay server name. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.