0

I tried to deploy a .wsp solution to my SP farm.

But I met the following error:

Last Operation Result: Some of the files failed to copy during deployment of the solution.

Last Operation Details: V-SERVER1U : http://v-server1u/ : SharePoint - 80 : Error: The web.config is invalid on this IIS Web Site: D:\InetPub\wss\VirtualDirectories\80\web.config.

There is another suggested solution as follows, but I am unable to locate the service in my server.

In Central Administration-> Operation-> Services on Server, please stop the Windows SharePoint Services Web Application service, SharePoint will remove the sites in IIS. And then start the Windows SharePoint Services Web Application service again, SharePoint will recreate the sites in IIS based on information stored in configuration database.

I also tried to implement -Force in SP Management Shell deployment command, but met the following error too:

Install-SPSolution : This solution contains resources scoped for a Web application and must be deployed to one or more Web applications.

I have no other possible solutions to fix this. May I know how can I resolve it?

0

The service name in your post is “Microsoft SharePoint Foundation Web Application”. You could stop and re-start the service “Microsoft SharePoint Foundation Web Application” in Services on Server.

enter image description here

To troubleshoot the issue, you could re-deploy the .wsp solution in the site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.