0

So I have an odd situation.

I'm working in 2 different document libraries. When I go to grab the URL of a document in one of them I get a basic directory that has the full path

sharepoint.com/sites/siteName/documentLibraryName/documentName

That all seems pretty normal.

Inside of the other document library I get: sharepoint.com/sites/siteame/documentLibraryName/_layouts/15/DocIdRedir.aspx?ID=.....

The only difference between the 2 are one was created in 2016 and the other uses folders and was migrated to 2016.

While the _layouts/15/DocIdRedir.aspx?ID= URL will get me to the document and I'm able to view it but in the address bar it will show the actual path instead of the redirect link with ID.

I've attempted to load a brand new document in to the "DocIdRedir" library thinking maybe it had to to with the migration from 13 to 16 but it still add the _layouts/15/DocIdRedir.aspx?ID= to the document URL

Any suggestions or assistance would be greatly appreciated

0

If you see DocIdRedir.aspx, this means the Document ID feature is enabled. This assigns a DocId on a per-Site Collection basis.

You can disable the DocId feature to go back to the other URL. If you find out that breaks someone's workflow or config, you can re-enable it and the DocId for each document will still be preserved and the links will begin working again (might take a crawl, though).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.