0

The following errors are showing up in the logs a couple times per day:

ERROR CanUpgrade [SPConfigurationDatabase] failed
SharePoint Foundation Upgrade SPUpgradeSession ERROR Exception: Login failed for user 'domain\machinename$'

I have checked the patch status, servers in farm, and have run the SP Config wizard, and I can't find any component claiming to need an upgrade. Is there any way to track down what is causing this error to be thrown, or why it's using this account to access the config database?

This issue was blogged about here, with a recommendation to add the account as a shell admin, but granting permissions to a local machine account doesn't seem like a best practice. Any thoughts?

  • Maybe you get some useful information in ULS-debuglog or in SQL-Server log? – MHeld Feb 27 at 7:22
  • under which user you are running the PSCONFIG? – Zdeněk Vinduška Feb 27 at 7:58
  • I ran psconfig as the setup user, but again, this error is occurring a couple times per day, but not from running psconfig. – Mike2500 Feb 27 at 16:22
1

1.This error is not related to the PSConfig execution.

  1. I agree that the granting the machine name is not best practice in terms of security.

  2. I had a ticket open for that case with MS and their advice was to grant the access to machine to only config DB (no access to content db). from that point on don't have those issues.

Unfortunately I cannot share the internal communication details with MS Premier Support.

I ran other farm without that setting and apart from noise in ULS I don't see any negative effect on that farm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.