1

New MinRole SharePoint 2019 farm, new SSA created with Central Admin or Powershell (tried both ways and got the same error described in this question). Using Powershell, I created a clone of the active topology and after I created all its components and running $clone.Activate() I get the following error:

Exception calling "Activate" with "0" argument(s): "Topology activation job died prematurely, the topology already is in Activating state." At line:1 char:1 $clone.Activate() + CategoryInfo : NotSpecified: (:) [], MethodInvocationException + FullyQualifiedErrorId : SearchTopologyActivationException

I am logged as the farm account on the Server with MinRole: Application with Search and running Powershell ISE as Admin. I already recreated from scratch a new SSA created with Central Admin and this one I created it with Powershell, but getting the same error. $clone.State = Activating and has been stuck in that state since yesterday.

noderunner.exe is located at D:\Microsoft Office Servers\16.0\Search\Runtime\1.0

Any ideas about how can I resolve this error?

  • On both servers I checked noderunner.exe.config file and value is <nodeRunnerSettings memoryLimitMegabytes="0" /> so nothing to change. – MLC Feb 26 at 14:38
  • Usage Application Status: Online – MLC Feb 26 at 14:51
  • Please check ULS-Logs for the "job-application-server-admin-service" timer job. Maybe you will find some helpful errors there. – MHeld Feb 26 at 15:05
  • In ULS logs for that timer job found "Unable to get systemmanagerlocation from db". Any suggestion about how to make it work? – MLC Feb 26 at 15:31
1

Using Central Administration, logged as the farm account I deleted SSA and recreated it and then I was able to get the topology working thanks to this link being noderunner.exe the issue due to Log on as account used for Windows services SharePoint Search Host Controller and SharePoint Server Search 16 not being an admin account.
Summary of steps performed:

  1. Installed Procmon.exe on the Search Server and using the "Process Tree" view I confirmed that there were several "noderunner.exe" processes under hostcontrollerservice.exe (more than the amount of topology components that I have) that were started but ended immediately.
  2. In Central Admin>Security>Configure Service Accounts, changed the account for the 2 following Window services:

    • Search Host Controller Service - changed it from services account to farm account
    • SharePoint Server Search - changed it from crawl account to farm account
  3. Using Powershell created a new search topology, added the search components to it and activated it. Deleted the default topology that was showing Inactive and verified that there were only one topology active after that (the new one)

  4. Went to Search Administration and then saw all topology components listed with a green check showing they were all working properly.

  5. Changed the service account for both services back to the non-admin account one by going to Central Administration>Security>Configure Service Accounts

  • You saved me a lot of... time, nerves and greyed out hair. Espacially the points 2 and 5 are the critical ones. – airliner Oct 8 at 9:17
  • @airliner I am very glad my answer to this issue helped you resolve yours. Thanks for letting me know by leaving your comment. – MLC Oct 9 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.