1

I have 2-tier architecture i.e. SharePoint 2013 and SQL 2012 servers. I have configured the SSRS in SharePoint mode from SQL 2012 SP1 in the SharePoint server by following this link.

The SSRS reports are working desirably in the web application. But from today, I am facing issues while accessing the SSRS reporting pages:

For more information about this error navigate to the report server on the local server machine, or enable remote errors


An unexpected error occurred while connecting to the report server. Verify that the Reporting Services Service Application mapped to this web application is available OR the report server is available and configured for SharePoint Integrated mode.


An internal error occurred on the report server. See the error log for more details. ---> Microsoft.ReportingServices.Diagnostics.Utilities.InternalCatalogException: An internal error occurred on the report server. See the error log for more details. ---> System.Runtime.InteropServices.COMException: Retrieving the COM class factory for component with CLSID {BDEADF26-C265-11D0-BCED-00A0C90AB50F} failed due to the following error: 800703fa Illegal operation attempted on a registry key that has been marked for deletion. (Exception from HRESULT: 0x800703FA).

While checking the association of the SSRS application with web application/s, found below message:

There are no web applications available to associate with this SQL Server Reporting Services Service Application

I have checked everything and it was as per the Microsoft best practices.

Any help will be appreciated as I require to fix it as soon as possible.

0

I have seen this error before in combination with other systems. One or both of the following solutions solved it:

Solution 1:

  • Open the Group Policy editor (Gpedit.msc) on the affected server.
  • Open the UserProfiles folder in the following path: Computer Configuration > Administrative Templates > System > UserProfiles.
  • Locate the Do not forcefully unload the user registry at user logoff setting.
  • Change the setting to Enabled.
  • Reference: 800703fa Illegal operation attempted ...

Solution 2:

  • Go to IIS Manager, select the Application Pool for your web application and click Advanced settings, change the value for "Load User Profile" to "true"
  • Reference: COM: Intermittent error 800703fa: Illegal Operation attempted on a registry key
  • Note: I have opened a Microsoft ticket to get confirmation that this IIS-change will be a supported one for a SharePoint WebApplication. This was confirmed.
  • I have applied both solutions. Can you please let me know the next step to do? – Divya Sharma Feb 27 at 4:10
  • Sorry, I cannot provide any further steps. One or both above solution solved that problem for me if i had the error 800703fa Illegal operation attempted on a registry key that has been marked for deletion. – MHeld Feb 27 at 7:18
  • Means you didn't need to perform any SSRS related configuration after executing the one or both the above solutions and your reports start working again as normal. Am I understood correctly? – Divya Sharma Feb 27 at 7:26
  • I didn't have that error in context of SSRS. But i had it in some different scenarios (SecurityTokenService, UserProfileService). As the root-cause is always the same (user logoff in the background, HKCU registry-hive no longer accessible by application), i provided my answer. – MHeld Feb 27 at 7:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.