0

Recently there was a IIS features reinstallation done on my server to resolve FBA login issues. The login is fixed now, but I am facing web part errors.

Error:

Web Part Error: A Web Part or Web Form Control on this Page cannot be displayed or imported. The type MROWebPartCollection.InventoryWP.InventorySummary.InventorySummary, MroWebPartCollection, Version=1.0.0.0, Culture=neutral, PublicKeyToken=7ebf4da56cd32d36 could not be found or it is not registered as safe. Correlation ID: ee5dc29e-5e00-a069-cd71-6d61fb5b4809.

This occurred to all my web parts.

I tried redeploying my .wsp file but to no avail.

In web.config, the safe control entries for my web part still exists.

May I know if the IIS features re-installation will require me to update the PublicKeyToken of my web parts in the web config?

Thank you.


Added SafeControl from the web application web.config:

  <SafeControl Assembly="MROWebPartCollection, Version=1.0.0.0, Culture=neutral, PublicKeyToken=7ebf4da56cd32d36" Namespace="MROWebPartCollection.InventoryWP.InventorySummary" TypeName="*" Safe="True" />

I have also tried changing Namespace to include extra .SearchProduct as per the error message. But it gave the same error as well.


Namespace Differences:

  1. Web Part Properties in VS enter image description here

  2. Web Part error in SP site enter image description here

  3. Config file web part namespace

SafeControl Assembly="MROWebPartCollection, Version=1.0.0.0, Culture=neutral, PublicKeyToken=7ebf4da56cd32d36" Namespace="MROWebPartCollection.InventoryWP.InventorySummary" TypeName="*" Safe="True"

  • probably the SafeControl in web.config is not correct. can you copy here the SafeControl from the web application web.config where you are facing this issue? – Zdeněk Vinduška Feb 22 at 7:20
  • @ZdeněkVinduška added in – gymcode Feb 22 at 7:29
  • Try to find the assembly details and check if there is nothing different: Open the GAC. Right click on your dll and then click properties. – Zdeněk Vinduška Feb 22 at 7:36
  • Have you run SP Config Wizard after re-installation IIS features. – Marek Sarad Feb 22 at 15:22
  • @MarekSarad Nope, SP Config Wizard was not run after that. Does it cause an impact? – gymcode Feb 25 at 4:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.