1

enter image description hereI want to create a UPA on a second WFE that serves as a failover WFE server, however the list of "Select the machine in this farm on which you would like to run Profile Synchronization process." only has the first WFE listed .. How can I add a new UPA for the second server to be able to run it when the first server is down?

enter image description here

  • which SharePoint version you are using? – Waqas Sarwar MVP Feb 21 at 14:22
  • 2013 on premise – Saz Mifsud Feb 21 at 14:23
  • are you using the MIM or ADI or anything else? – Waqas Sarwar MVP Feb 21 at 14:23
  • how can i check please? – Saz Mifsud Feb 21 at 14:24
  • Forefront Identity Manager Synchronization Service and everything is installed and running.. - i added an image, that list only lists the first front end sevrer, but not the actual one where i want to create upa – Saz Mifsud Feb 21 at 14:25
1

You can only run one instance of the User Profile Synchronization service on a farm. it is kind of limitation. You cant have multiple instances of UPA sync.

But you can start User profile Service instance on multiple servers in farm.

Plan for the synchronization server

Try to run the below script against each server, replace Servername with ur each time. (this will list the UPA service instance on each server)

Add-PSSnapin Microsoft.SharePoint.Powershell
$TypeName = "User Profile Synchronization Service"
$ServerName = "SERVERNAME" #Replace with your server name where the service is stuck on Starting

Get-SPServiceInstance | where-object {$_.TypeName -eq $TypeName -and $_.Server.Address -eq $ServerName}
  • You can only run one instance of the User Profile Synchronization service on a farm. The computer on which the User Profile Synchronization service runs is called the synchronization server. <-- and what if the sync server is down? – Saz Mifsud Feb 21 at 14:34
  • You have to manually start the sync service on the 2nd server. – Waqas Sarwar MVP Feb 21 at 14:35
  • Ok so I do not know if this is the root issue of my problem at this point. I have 2013 Designer Workflows running, but when the 1st WFE server, where UPA is hosted, is down, I get authorization errors on the workflow: An exception occurred when trying to issue security token: UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.ApplicationProperties ProfilePropertyCache does not have Claims Authentication Isnt that because of USer Profile Sync? – Saz Mifsud Feb 21 at 14:37
  • I also have these event logs when I run sync on the second server: The management agent "MOSS-UserProfile" failed on run profile "MOSS_EXPORT_GUID" because the server encountered errors. – Saz Mifsud Feb 21 at 14:54
  • 1
    i think, User profile service should be on all server in the farm, i am not sure, could you please run the script to check. – Waqas Sarwar MVP Feb 21 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.