I want to enable external sharing for the tenant-my.sharepoint.com domain so that external users can see people's profile pictures, which are stored at https://tenant-my.sharepoint.com/User%20Photos/Forms/Thumbnails.aspx?id=%2FUser%20Photos%2FProfile%20Pictures. Right now, external users only get the default anonymous grey faceless picture when profile pictures show up, and when they try to open the profile picture in a separate tab, it says that external sharing is disabled for the image.

1 Answer 1


Go to SharePoint admin center-> site collections, choose the site collection https://tenant-my.sharepoint.com and click sharing.

enter image description here

  • How weird, it looked like that setting was already on allow anonymous access links, but it wasn't working until I resaved the settings. Thanks very much!
    – gtew234
    Commented Feb 20, 2019 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.