0

I have reinstalled Workflow Manager on my SharePoint Server, as I wanted to point it to a new DB Server, I ran the following commands:

$config = (Get-SPSecurityTokenServiceConfig)
$config.AllowOAuthOverHttp = $true
$config.AllowMetaDataOverHttp = $true
$config.Update()

Enable-SPFeature -Identity WorkflowServiceStore –Url #url#

Register-SPWorkflowService -SPSite "#url#" -WorkflowHostUri "#wf url#" –AllowOAuthHttp -Force

My 2013 Workflow calls a webservice. For some reason this web service method is being called several time since the above change (I know this because I keep a text file log and it keeps logging infinitely, and wf never stops) - any ideas what could have caused this and how I can fix it please? I also tried re-creating the workflow but that did not help

  • check the ULS logs and Workflow manager logs? is the Workflow Manager is up and running? – Waqas Sarwar MVP Feb 18 at 19:09
  • Where do I find Workflow manager logs please and how do I check if it is up and running (although workflows ARE triggering so I assume it is) – Saz Mifsud Feb 18 at 19:13
  • on server where workflow manager install,(open workflow pwoershell console) run get-sbfarmstatus & get-wffarmstatus ? also check the event logs (workflow and Service bus) on workflow manager server.... – Waqas Sarwar MVP Feb 18 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.