0

enter image description hereI've made a 2013 approval workflow in designer.

Whenever someone other than me submits a new list item the first steps of the workflow run (the submitter gets an email notification) but seconds after submission the workflow status goes straight to “Rejected” status and the approval task emails are not sent.

i tried giving write permissions to the task and history lists, but it didn't work.

would appreciate some help Shira

  • Could you post a screenshot of your workflow? – Mike2500 Feb 18 at 12:50
  • hi,the workflow is in Hebrew, so i'm not sure it will do much help. – Shira Feb 18 at 12:56
  • Hello its caused by the App Step and then you publish under you. Probably you need impersonation step instead of App Step and after editing WF, publish it under Site Collection Administrator. – Zdeněk Vinduška Feb 18 at 13:20
  • thank you for your answer. i tried it with and without the app step. in 2013 workflow, the app step supposed to replace the impersonation step that was in 2010. i am a site collection admin, so how do i publish it under Site Collection Administrator? – Shira Feb 19 at 7:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.