I have created a new spfx webpart from yomen generator. and deployed to sharepoint. It is working in the classic sites and workbench page.

But in the modern site, modern page. it is not showing web part properties in the webpart properties pane. its showing error saying No settings to change for this web part..

enter image description here

This is simple spfx webpart without any customization directly deployed newly created webpart and testing.

Please help with this ASAP.

  • Have you tried adding the web part to a another modern page that has no other web part on it?
    – Mihail
    Commented Feb 14, 2019 at 11:09
  • Actually this is the only webpart in that page. Commented Feb 14, 2019 at 17:28

2 Answers 2


I am not sure what was the actual issue. I uninstalled the Gulp, yo, Microsoft SharePoint generator. and installed again. and generated a new application which started working. Earlier my SPFX version was 1.7.0 now it is 1.7.1. Hoping that there was some issue with the SPFX package version or other packages related to this application.


I had the same problem. Here is what worked for me:

I changed:

import { IPropertyPaneConfiguration, PropertyPaneTextField } from '@microsoft/sp-property-pane';
import { BaseClientSideWebPart } from '@microsoft/sp-webpart-base';


import { IPropertyPaneConfiguration, PropertyPaneTextField, BaseClientSideWebPart } from '@microsoft/sp-webpart-base';

and I changed:

protected get dataVersion(): Version {
    return Version.parse('1.0');


protected get dataVersion(): Version {
    return Version.parse('1.1');

Then, I increased the WebPart version in package-solution.json.

I think increasing the data version is the main reason it worked. However, I also deleted the app entirely before re-deploy:

  • I removed the app from the site at https://your-sitecollection.sharepoint.com/sites/your-site/_layouts/15/viewlsts.aspx
  • I emptied the recycle bin at https://your-sitecollection.sharepoint.com/sites/your-site/_layouts/15/AdminRecycleBin.aspx?ql=1
  • I emptied the second-stage recycle bin at https://your-sitecollection.sharepoint.com/sites/your-site/_layouts/15/AdminRecycleBin.aspx?View=2&ql=1
  • I removed the app from the app catalog at https://your-sitecollection.sharepoint.com/sites/appcatalog/AppCatalog/Forms/AllItems.aspx
  • Finally, I installed and added the WebPart the usual way, again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.