0

I clone the mentioned SharePoint App. Did a npm install. When I run gulp serve, it shows the following error. Please do the needful.

[SPLoaderError.loadComponentError]: ***Failed to load component "41e37f03-2ea8-4f19-b77a-f2121a1e7c45" (SpSecurityWebPart). Original error: ***Failed to load entry point from component "41e37f03-2ea8-4f19-b77a-f2121a1e7c45" (SpSecurityWebPart). Original error: Error loading https://component-id.invalid/41e37f03-2ea8-4f19-b77a-f2121a1e7c45_0.0.1 Cannot find module "./spSecurity.css"

***INNERERROR: ***Failed to load entry point from component "41e37f03-2ea8-4f19-b77a-f2121a1e7c45" (SpSecurityWebPart). Original error: Error loading https://component-id.invalid/41e37f03-2ea8-4f19-b77a-f2121a1e7c45_0.0.1 Cannot find module "./spSecurity.css" ***CALLSTACK: t@https://spoprod-a.akamaihd.net/files/sp-client-prod_2019-02-01.006/sp-webpart-workbench-assembly_en-us_ab51ffb0e2576c31246f5ed33d950474.js:272:16049 t@https://spoprod-a.akamaihd.net/files/sp-client-prod_2019-02-01.006/sp-webpart-workbench-assembly_en-us_ab51ffb0e2576c31246f5ed33d950474.js:1143:21050 WEBPACK_AMD_DEFINE_RESULT

  • When trying to run any gulp task in Node 10.15.0, I get the following error: const types = internalBinding('types'); For this issue, did a npm install natives@1.1.6. The ReferenceError: internalBinding error is resolved. Then again I did the above mentioned steps. But having the same issue. – Mohamed Musthaque Feb 13 at 11:16
0

SPFx currently doesn't support the latest Node 10.15.0 version. It doesnt support 9.x or 10.x version

You need to install the Node v8.x version.

Also, once you do that, you need to delete the node_modules folder and re-run npm i again and then test the project.

Reference - Set up your SharePoint Framework development environment

Install - NodeJS LTS version 8.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.