2

This is a production SharePoint 2016 MinRole farm with 2 servers (AppSearch & FEDistCache). After a network outage, in the Health Report I am getting the following configuration Error:

Title: Product / patch installation or server upgrade required.

Explanation: All required products must be installed on all servers in the farm, and all products should have the same patching and upgrade level across the farm. Upgrade is required on server FEDistCache. Without the upgrade, the server is not in a supported state.

Fact: It needs to get updated to a recent KB but I want to get this resolved before I do an upgrade.

Things I have tried/reviewed:

  • rebooted both servers
  • Reanalyze Now after rebooting the servers but Error keeps showing up under review problems and solutions.
  • compared Windows update between both MinRole servers and they are the same
  • On Manage Patch Status both servers have the same version installed and same KB
  • On Servers in Farm, Status = No Action Required for both servers.
  • Upgrade Status = Succeeded on the last update.

Is there any troubleshooting that I could do to resolve this without running an upgrade on the farm?

  • Get-spproduct in powershell might help your servers. blogs.technet.microsoft.com/stefan_gossner/2016/08/09/… – Christoffer Feb 12 at 21:38
  • Check the status of DC, use-cachecluster , Get-cachehost, make sure they are up and running – Waqas Sarwar MVP Feb 12 at 21:50
  • @WaqasSarwarMVP I checked and AppFabricCachingService is UP; Status: Online – MLC Feb 13 at 15:26
  • did you ran the get-spproduct? also make sure, Farm admin account & app pool accounts have the proper permission on the Content Databases, config databases – Waqas Sarwar MVP Feb 13 at 15:34
  • @Christoffer get-spproduct is used when patching SharePoint, based on that link that you posted and in this case I don't want to patch the servers, I would prefer to resolve this error first. I was thinking if that particular server might be out of sync with the config DB. – MLC Feb 13 at 15:38
0

Issue auto resolved. Logged into Central Admin as the farm account and clicked Reanalyze Now and got a Success. Nothing was changed and I didn't run get-spproduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.