0

Good Day, On my SharePoint site collection I use managed metadata navigation to apply friendly URL to the site pages. Every term is tagging and on the “Navigation” tab has the options “Show on the current navigation” and “Term-Driven Page with Friendly URL” selected. Visitors (users with read only) have read access to the term target page.

The users with “Edit” or “Contribute” permission level can see all terms on the left navigation. But the Visitors can’t see some terms.

I can’t find the difference in selected options for the available and not available terms for readers. I followed this recommendations . But it didn’t help. I looked here.

But if I select “Simple Link or Header” for the term, the Visitors can see it, but I can’t to set the friendly URL for it. I follow the AndrewG22’s recommendations. It didn’t help too.

I would be grateful for any information.

  • I tried to test the visible term for readers. I copied this term and named it “COOOPY”. The user Alex with reader’s rights can see the “COOOPY” in the left navigation with the target page A. Then I changed the target page A for the “COOOPY” to the target page B (the page of not visible term). And Alex lost ability to see the term “COOOPY”. I checked the Alex’s rights for the target page B. He has the ‘reader’ access… Alex is a member of AllUsers and “Site Name - visitors” groups. This groups have the “reader” access level to the page B. Page B is not checked out. – Anonymous Feb 8 at 7:14
  • I changed the target page B (the page of not visible term) for the term “COOOPY” to the some empty page from the "Site Pages". The term "COOOPY" is still not visible for Alex account... Alex has "reader" access to the "Site Pages" library. The question is still actual – Anonymous Feb 8 at 7:14
  • The question is still actual. Any ideas? – Anonymous Feb 12 at 7:03
  • I make full access crawling. The term "COOOPY" with new empty target page became visible for Alex account. I added the default style table to this empty page (with one empty cell). Then I saved my changes. The term "COOOPY" was lost for Alex account again. – Anonymous Feb 13 at 5:53
  • For the "COOOPY" target page I opened the Gear menu, selected the option "Together with" and set the reader access for All. After full access crawling the term became available for the reader. But now the reader can't see the term for which Site Home page was selected as target page... Someone, please, tell me what the reason of that behavior – Anonymous Feb 13 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.