5

We have an issue with Sharepoint Web Parts which have worked perfectly fine in the past, but seem to have broken sometime within the past month without change on our side. One modern web part on the page is fine, however upon adding a second, neither Web Part's configure menu works any more (clicking 'configure' doesn't do anything, no console errors)

Our temporary workaround is to configure a single web part and export as a .webpart file multiple times.

We have confirmed this issue is not specific to our solutions as a fresh web part (latest dependencies, fresh generation, single property for testing) produced the same result.

Steps to reproduce -

  1. Add a Modern SPFx webpart to a classic SharePoint site page
  2. Confirm the configure menu is working
  3. Add the same webpart again
  4. Confirm the configure menu is now not working
1

Update: This has been identified as a bug by the SharePoint dev team, and a fix has been deployed -

https://github.com/SharePoint/sp-dev-docs/issues/3345#issuecomment-460534157

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.