1

I have created a simple workflow with Send Email action in SharePoint 2013 document library, the email will send when a new item added to document library.

When an item created in document library, the workflow get suspending with the below error.

RequestorId: 26df5cee-92d9-9ac0-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 500 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPClientServiceRequestDuration":["77"],"SPRequestGuid":["26df5cee-92d9-9ac0-aacf-b0c020be4369"],"request-id":["26df5cee-92d9-9ac0-aacf-b0c020be4369"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":["15.0.0.4675"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Cache-Control":["max-age=0, private"],"Date":["Wed, 30 Jan 2019 04:49:08 GMT"],"Server":["Microsoft-IIS/8.5"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

Emails triggering fine in other sites, the workflows get suspending with particular to this site.

Kindly provide suggestions to get resolve the issue.

Thanks in advance.

  • It is necessary to increase the user's rights to the list of workflow history to the level of "Collaboration" permissions. – Fox Jan 31 at 9:20
0

I had same problem few weeks ago in SPO, probably the same cause. Follow instructions:

  1. Check under which Account is running this workflow - if its some Service Account it has not email address probably
  2. Go to All Users table - its on Root Site Collection: https://company.sharepoint.com/sites/zvi/_layouts/15/people.aspx?MembershipGroupId=0 and find your Service Account
  3. There is not any email address, so the workflow has problem with sending email when sender has not email address. You can set email address here or you can set it in UPS or AD (the email can't existed in real you only need some email address from which will be send this email)

Added another solutions:

  1. Check if your Log in History action has not exceeded limit of 255 characters.
  2. Check if you have proper permissions to History List and Workflow list on this site.
  3. Check if in library where is workflow in not set "Require documents to be checked out, before they can be edited
  4. Do full User profile Synchonization
  5. Try this POST

If this is ok, there can be problem with some permissions, have you published this workflow with the same account? It's 100% same?

  • Thanks for your prompt response. I am triggering the workflow with my user account and sending the email to my account only. The workflows are intermittently suspending with HTTP 500 error. Could you please suggest what's causing the problem – user399731 Jan 31 at 9:18
  • Added some more solutions, try them – Zdeněk Vinduška Feb 2 at 18:48
0

Are you able to use the Alert options in this site? https://support.office.com/en-us/article/create-an-alert-to-get-notified-when-a-file-or-folder-changes-in-sharepoint-e5a79e7b-a146-46da-a9ef-d65409ba8918

Maybe you don't need a workflow because the alert functionality is enough.

If you cannot set up Alerts then it's possible that this site isn't configured to send emails.

  • Alerts are working fine in SharePoint list & document libraries, but we have an requirement to send an email through workflow when an item created in list/library. But the workflow gets suspending with HTTP 500 error. – user399731 Feb 5 at 7:09
  • can anyone suggest on the issue to get it the issue resolved. – user399731 Feb 7 at 3:34
  • Can use share more logs from ULS? I think you can filter by the Correlation ID with the value of the "SPRequestGuid":["26df5cee-92d9-9ac0-aacf-b0c020be4369"] from your error message. Ofc, when you start a new workflow to create new logs this SPRequestGuid will change and you need to use the new value when filtering the ULS logs. – David Sass Feb 9 at 19:37
  • UpdatedConcurrencyException: The object UserProfileImportJob Name=User Profile Service Application_ProfileImportJob was updated by another user. Determine if these changes will conflict, resolve any differences, and reapply the second change. This error may also indicate a programming error caused by obtaining two copies of the same object in a single thread. Previous update information: User:[UserAccount]Process:OWSTIMER (17924) MachineTime:December 29, 2017 01:04:36.0000 Current update information: User:[UserAccount] Process:OWSTIMER (10128) Machine:[] Time:February 11, 2019 10:58:40.1232 – user399731 Feb 11 at 9:23
  • Getting the ULS logs as mentioned above. Could you please help me on to get it resolve.And the workflow get suspending particular to this site collection and intermittently it's getting suspending. Thanks in advance. – user399731 Feb 11 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.