0

I have a site collection with root web and subwebs. The full crawl is indexing everything in the root web and subwebs. The incremental and continuous crawls only indexes the content in the root web, but never takes the content in the subwebs. None of the the items inside the subwebs are logged by the incremental crawler in the crawl log, not even errors.

I have however another site collection with a similar structure, in the same farm, but there, the full, incremental and continuous are working properly in webs and subwebs.

SharePoint patch level is December 2018.

I even tried CrawlLog.RecrawlDocument() but the crawler still seem to ignore the items added to the queue like that.

0

Incremental Crawl and Continues Crawl crawls last modified content. If there is no modified content in the subsite, then the Incremental Crawl and the Continues Crawl will not crawl the subsite.

And you could check if there is error message in the crawl log.

More references:

Types of Crawl in SharePoint 2013.

Continuous crawl in SharePoint 2013.

  • Obviously, there is changed content in the subwebs, the question would not make sense otherwise. – Sergiu Jan 28 at 14:10
  • I suggest you could check if there is crawl rule to exclude the subsites. And you also could reset index. – Amy_MSFT Jan 29 at 1:00
  • I checked the crawl rules and no exclusion will apply. I also did a reset index. – Sergiu Jan 30 at 7:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.