1

In our SharePoint 2013 farm, search service full crawl never completes and shows link running always. If I am forcefully stopping and scheduling the incremental crawl, then instead of starting incremental full crawl gets started again.

Please advice me on how should I proceed to resolve this issue.

Thanks.

1

Full crawl must be done at least once, after this you can start incremental crawls. We had some SP farms where full crawl takes 4 days...

You can split content to more Content Sources, where you will define starting Site Collections, this is the best way. Also check the SharePoint server usage, it cannot be at 100%, if you have not enough CPU or RAM, you should add more restouces to the server.

Full crawl can take up a hours, days, it depends on:

  • size on crawled content
  • security - how many there are unique permissions, lots of users, groups, etc
  • settings of Search - Performance Level, correctly Content Account, etc
  • hardware of your servers
  • correct topology

Here is the MS link check it.

If you want more help, just contanct me, I need more information or we can do some TeamViewer session.

  • Can I split the bigger content DB?, If yes please guide on this. – Kailash Sahoo Feb 15 at 12:43
  • 1
    Content DB can be splitted by Site Collections. You can create new site collection in Central Admininstration > Application Management > Content Databases > Creat new Database. After this you can do Move-SPsite to the new databases, it will take some time, do it in weekend: docs.microsoft.com/en-us/powershell/module/sharepoint-server/…. Dont forget to vote up for my answer and mark it, thanks :) – Zdeněk Vinduška Feb 15 at 12:50
  • Thanks for the reply.Full crawl successfully completes if I attach any content db of size around 200 GB, but when I attach the content db of size around 500 GB[This is the actual content db where I am facing the issue] the full crawl never completes, always shows as in progress. I mean, as the DB is already heavy in size, the site collection will make the new Content DB large again. How to override that Thanks in advance. – Kailash Sahoo Feb 15 at 12:55
  • you have here only one site collection in this 500GB large databases? – Zdeněk Vinduška Feb 15 at 13:01
  • 1
    You cannot simply split Site Collection, if you want to "split" Site collection you need to use Export-SPWeb and Import-SPWeb for webs you want to split, but it takes more time. – Zdeněk Vinduška Feb 18 at 7:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.