I have a problem, where if I open a document from SharePoint Document Library, I couldn't edit it locally, the file requires to be saved locally. I cannot Checkout/Checkin, cannot edit it. It just says "[Read-Only]". Note that permission and settings has been checked properly.

Monitoring the traffic between my computer and the SharePoint server, I noticed that I am missing some HTTP Headers that are needed for Office Client to be able to do document editing.

I am missing the following HTTP Headers from the server:

  • X-MS-InvokeApp
  • MS-Author-Via

So subsequently, the Office Client will not use the document editing mechanism, instead it is downloading the document for local copy.

I have read the following article https://msdn.microsoft.com/en-us/library/dd906383(v=office.12).aspx but at step #9 the server is not sending these HTTP Headers. What could possibly go wrong? Is it a client problem? I tried to checkout the document from another network region with success result, so I don't think it is a server related problem, however I am stuck in where to start troubleshooting this problem.

Could someone points a direction to me where to start looking into this problem more thoroughly?


Edit: some additional info

SP: 2013 Office: 2016 IE: 11

  • 2
    Your SharePoint version? Your Office version? Your browser? – teylyn Jan 24 at 2:48
  • Wild guess: Could you try to disable modern authentication on the client? Maybe Office will behave differently if you do so: answers.microsoft.com/en-us/msoffice/forum/all/… – engineerer Jan 24 at 7:13
  • Have you set firewall? This is inside company (Intranet) or Extranet problem? – Zdeněk Vinduška Jan 24 at 9:23
  • @ZdeněkVinduška this is internal network, firewall should not be an issue, as ports used are 80 and 443 only, but CMIIW. thanks – Arief Jan 28 at 4:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.