1

I have created a list with two lookup columns. Those columns are filled with an email address. Besides I have created a workflow to make an email sent if the list is saved, however now email is sent. I can see the email is returned as #name@company.com. Is there a way to resolve this? I have seen something about writing a code but I do not know how to get there? Thank you BR

Maybe I am in the wrong field as I see you are using a string as I am working in here? The field Hotelname:HD is the lookup field from another list: enter image description here

Where do I have to go the second option, change the variable? I am not yet that familiar with SP, thx

0

For the Flow problem, can you add here a screenshot? I tried it with SP Workflow 2010 and it works correctly. In WF use simply return field: Lookup Value (as Text).

enter image description here

In Flow you can create Variable and in variable use expression Replace('#','') or Replace("#","") for the email input. It will work.

" or ' depends on environment location i think.

enter image description here

  • Please don't add the exact same answer to different questions. Either the questions are duplicate and should be merged, or the answer given should be different. See sharepoint.stackexchange.com/questions/256343/… – Benny Skogberg Jan 23 at 10:15
  • 1
    what? i added this answer to another question, my mistake, i fixed it. I editet both answers and now it is correct. – Zdeněk Vinduška Jan 23 at 10:16
  • Maybe I am in the wrong field as I see you are using a string as I am working in here? The field Hotelname:HD is the lookup field from another list: see added printscreen in the question – Remko Groot Jan 24 at 6:41
  • Oh, this is the added another field from the lookUp, this is not the base lookup, where you are selecting item, but the "more fields" option, right? – Zdeněk Vinduška Jan 24 at 7:54
  • I have "Lookup for string" because i set string variable, try to use variables if the value will be correct, if not, check values in sharepoint fields for hotelname:HD – Zdeněk Vinduška Jan 24 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.