0

When you create a new navigation item in a hub site navigation, there is no option to leave the URL blank. The top level menu items have to link to something. If you leave it blank, you can't save it. If you add #, it links to the root. When you have sub items, the natural behavior is to click on the menu to see the children. This is causing a page reload.

Does anyone know a workaround to not have the top level navigation item link to anywhere?

[TopLevel]

0

Yours is indeed a very valid scenario. But unfortunately, at the moment it is not supported. We indeed require a URL for a hub navigation link.

There is also a user voice entry requesting the same capability from Microsoft. You can upvote it there. More upvotes might increase the chances of it being looked at by MS product team, no guarantees that it might actually implemented. Worth a try though :)

Would also suggest that you wait a couple of months, because new mega menu capabilites are going to be rolled out in the first half of 2019 and looks like it will solve this issue.

If it is a deal breaker for you, would suggest that you get rid of Hub Site and go ahead and implement your own navigation using SPFx extensions. There already a Github sample available which you can extend. It supports empty URLs and displays them as unclickable labels.

  • good answer. Tested and confirmed. Parent nav items still need a link (to save) but you can click the arrow to expand and sub items – Colbs Jan 23 at 20:23
  • Thank you for your clear answer. I will discuss this in the organization how we will best deal with this. – Noukie89 Jan 24 at 7:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.