0

I have created an InfoPath form using InfoPath designer. then I published it to SharePoint server 2016 document library. My issue is in submitting the form, everything before that works perfect. users can't submit this form unless they have permission such as Site collection administrator otherwise they wont. I tried to add these users to member group with the edit permission level, and also to owner group with full control permission level, but non of them worked. every time they click on submit button they get an error as the following. "***

the Form can't be submitted to specified SharePoint list or library. the SharePoint location may be read only or you may not have permission to access it.

***" I need your help. because I don't really understand why it is doing this.

The following are the current setting.... enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

1

looks like problem with List/ library permission, make sure the User have proper permission on that list / lib where you published the form. No custom permission or item level. check this: http://ukreddysharepoint2010.blogspot.com/2014/01/error-typethe-form-cannot-be-submitted.html

https://social.technet.microsoft.com/Forums/office/en-US/8f331ca2-26e8-4dd6-a76c-ecd365f68c88/unable-to-submit-infopath-form-due-to-permission-issue

  • Many thanks for your response. the first link is talking about setting item level permission for a list, where it wont work for me because i am using document library. for the second link, I already checked the list permission and made sure the required permissions are selected. – Osman Teyeb Jan 24 at 7:22
1

Users which will use this form need to have Contribute Permissions in the library/list where is the form published.

Another problem can be with Item-level Permission.

  • List Settings –> Advanced Settings
  • Change the "Item-Level Permissions" to Create and edit all items – users don't need item-level permissions on this list now.
  • Many thank for your response. I already gave Contribute Permission to the library. For changing the "Item-Level Permissions" I don't find it after following the steps you said above. still the form is not submitting and I am getting the same error. any other suggestion for do. – Osman Teyeb Jan 24 at 7:13
  • This must be set on document library, cause you are published the InfoPath Form here. go to Library Settings > Advanced Option > There will be Item-Level Permissions – Zdeněk Vinduška Jan 24 at 7:56
  • Thank you for your response. I am using document library, in the library settings > Advance settings > I'm not finding the item level permissions. – Osman Teyeb Jan 24 at 8:01
  • Provide us screenshots of library: 1 - versioning settings, 2 - advanced settings, 3 - permissons setting, 4 - content types (the main library settings), thank you – Zdeněk Vinduška Jan 24 at 8:27
  • I can't the screenshot to this comment but I have upload them and you can find them in coming link, 1drv.ms/f/s!AopqSb2icHn-nv9rkDL-xhaXTJmy_A – Osman Teyeb Jan 24 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.