2

I've modified my "Wanted" view of a classified ads list, grouped by Category, so that it doesn't display the annoying "Category:" text on each line. That works flawlessly when viewing the list independently, but when that list is viewed in a web part it persists in displaying the "Category:" text. No amount of refreshing or reinstating the "Wanted" view in the web part edit pane helps. When I create a View of a List, then choose that View for my web part, I expect both Views to look the same. What to do?

1

Looks like that is a common issue - here is a similar question and possible answers > https://social.technet.microsoft.com/Forums/ie/en-US/5d1de812-acf4-49ff-96a3-a6a113025cf1/list-view-remove-group-by-headers-column-names?forum=sharepointgeneralprevious

Not sure what version of SharePoint you're using, but here is some javascript that you might consider > https://spjsblog.com/2011/08/30/remove-group-label-in-grouped-list-view/

If you have access to SharePoint Designer, perhaps this will be more suitable > https://social.msdn.microsoft.com/Forums/sharepoint/en-US/f514fa73-5b35-402d-b43a-19f1580ca9bc/list-view-group-by-without-field-name?forum=sharepointcustomizationlegacy

Hope that helps.

0

Correct me if I'm wrong. I understand you that way, that you created a list, added the list view web part on a page and edited afterwards some view in the list. Right? In that case you just need to edit the page and switch the view settings of the web part to another and back to the wanted view again. Web Parts on pages just "import" the settings of a view to that specific moment and doesn't update the settings when the view changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.