3

I'm hoping this is something that you can help me with. I have a VM running SharePoint Server 2019, on Windows Server 2019 (Standard).

I'm using a SharePoint "publishing" site but for whatever reason Image Renditions / BlobCache does not work.

Summary of the problem

  • BlobCache entry is enabled in the web.config
  • Publishing features are all fully enabled
  • "Edit Renditions" menu appears in picture libraries
  • No corresponding errors in either the ULS or IIS logs

but ...

  • The defined blobcache location is always empty .. it is never populated
  • The "Image Renditions" do not work, and always return the full image size

Things I've already tried

  • I have performed numerous IISRESET and server reboots
  • I have triple checked the web.config entry and compared it to known working configurations
  • I have also triple checked the folder permissions - I can confirm that the application pool accounts and the built in .\WSS_WPG have "full control" to the target blob cache folder
  • I tried changing the blobcache location and creating the folder in advance
  • I tried changing the blobcache location and NOT pre-creating the folder (after loading the site the folder was created - with the correct permissions).

...

So what next?

I am at my wits end. I have done this dozens (hundreds?) of times in loads of different OS/SP permutations (MOSS 2007 / SP2010 / SP2013 / SP2016). This is the first time I've ever had a problem (beyond "turning it on").

oh .. one other thing

I do have one related error showing in the Event Viewer:

Source: Web Content Management Task Category: Publishing Cache Event ID: 5538 "An error occured in the blob cache. The exception message was 'Retrieving the COM class factory for remote component with CLSID {2B72133B-3F5B-4602-8952-803546CE3344} from machine SPSQL2019 failed due to the following error: 80070005 SPSQL2019.'."

This doesn't happen all the time, and seems to correspond to either a server reboot or IISRESET operation.

I believe that "80070005" means "Access Denied" and the CLSID relates to the Remote Automation DCOM component for Web Management.

I think this is SharePoint 2019 attempting to "configure" blob cache when IIS restarts .. so I've dismissed it for now as I've already manually done this in the web.config.

UPDATE - Permissions Issue? I tried adding the application pool account to the local "Administrators" group just to check .. and it worked!

Interesting the Event Viewer error also went away .. so I'm wondering if this is some new DCOM+ permission required in Server 2019 to allow creation of the Blob Cache folders?

3

Ok I have finally found the root cause for this issue.

I believe this is a bug relating to either Windows Server 2019, SharePoint Server 2019, or a combination of the both.

Basically, the application pool accounts do not have sufficient permissions to create BlobCache folders in a vanilla install of SP2019 (specifically on Server 2019).

There are 2 key permission changes needed, all of which should be applied to the local "WSS_WPG" group.

1) Initially there will be an error relating to a "COM Class factory" showing in Event Viewer (Event ID: 5538):

"An error occured in the blob cache. The exception message was 'Retrieving the COM class factory for remote component with CLSID {2B72133B-3F5B-4602-8952-803546CE3344} from machine failed due to the following error: 80070005 .'."

This comes about because the WSS Worker Process Group (WPG) doesn't have access to the Application Host Admin API for IIS 7.0 ("ahadmin").

This can be resolved by granting the WSS_WPG group Launch and Execution permissions to the "ahadmin" DCOM component (in Component Services).

You however can't do this without first taking "ownership" of the "ahadmin" registry key first: HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID{9fa5c497-f46d-447f-8011-05d03d7d7ddc}

2) After resolving the COM permissions above, and performing an IISRESET, you will next observe another error in Event Viewer (again with Event ID: 5538)

"An error occured in the blob cache. The exception message was 'Filename: redirection.config Error: Cannot read configuration file due to insufficient permissions"

Resolving this is simply by granting the WSS_WPG group "read" access to the IIS config folder (C:\Windows\System32\inetsrv\config).


Do another IISRESET and you should find that the BlobCache is now working correctly.

(It should be worth noting that this was all observed on a single machine .. but in a typical farm I would expect this activity required on all WFE servers).


I can only assume at this point that this is a platform issue.

Perhaps Server 2019 changed the default execution permissions? Perhaps the SharePoint 2019 installer doesn't correctly change these permissions?

Either way .. I have now replicated this error on two separate new Server 2019 / SharePoint 2019 machines.

  • 1
    The RegEdit Path HKEY_LOCAL_MACHINE\.. is incorrect, it should be HKEY_CLASSES_ROOT\.. (My Edit of this Post was denied) – Christian Herzler Mar 26 at 10:43
0

Good news! The July 2019 CU for SharePoint 2019 finally fixes this misbehaviour. Blob cache now works for SharePoint Server 2019 as it is supposed to.

Check the details: https://support.microsoft.com/en-us/help/4475529/security-update-for-sharepoint-server-2019-july-9-2019

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.