I have a document library which contains some Word documents that I'm trying to copy down to my local disk. I've opened the document library using Windows Explorer, and am dragging the individual files from that window to a folder on my local PC.

Some files work, but others are giving me this error (on Windows 7 x64):

The file name you specified is not valid or too long. Specify a different file name.

The filename in question is simply "Donations Policy.docx" - it's not a long filename. I've even tried simply dropping the file into the root of my D drive to see if it's the destination filename it's complaining about, to no avail.

On Windows XP the error is a bit more cryptic:

Cannot copy Donations Policy: Cannot read from the source file or disk.

Has anyone seen this error? I can't for the life of me determine why some files are throwing this error while others are copying just fine.


The files copy without any problem if we go into the doc lib's settings and turn off versioning.

The error must somehow be related to versioning, but the versions of these documents are not consistent with the error. Documents with versions less than one (eg 0.6) copy fine, others with versions like 1.2 are fine. My "Donations Policy" file is version 1.8 and it errors.

So for now we're working around it by turning off versioning for the duration of the file copy. I'd still love to hear from others who might be able to explain the error!

  • I am a pretty experienced user of windows and mac. I am stuck right now this also, there is always always something with windows that drives me nuts. I teard down one problem just to bump my head directly into another. I tell you, windows is sick compared to osx. Windows is a maniacs work.
    – user6464
    Jan 18, 2012 at 19:14
  • For me it worked. I was able to rename in the browser but not in the mapped drive. Does that mean there is an issue with the way I have mapped it?
    – user14802
    Feb 8, 2013 at 22:23

6 Answers 6


I found that this renaming problem occurs based on how the drive was mapped. For example, renaming files does not work if I map the drive with this address:


However, if I map the drive the following way and ensure I replace %20 with a space, then I am able to rename files:

\\example.com@ssl@987\Shared Documents\

This was only tested in Windows 7.

  • I was having this same problem. This totally worked for me on Win7: \mydomain.com@ssl@987\Shared Documents\ instead of using the URL. Thanks!
    – David
    Nov 30, 2011 at 21:46

It may be a coincidence that the files with the higher version numbers are the ones giving the error.

Is the pattern that files with a space in the file name give an error, but files without a space are OK?


I'd look in the SharePoint log files for possible errors, it could be that a generic error code is coming back to the OS when something else is happening in the underlying sharepoint layer.


I'm going to provide my own "answer" to this question to effectively close it off, because the problem is no longer occurring and I'm not 100% sure what fixed it.

All I know is that (temporarily) disabling versioning on the document library made the problem go away. After we were done copying the files, we turned versioning back on and it still didn't error. So I think right now it's anybody's guess.


how deep down in your site/folder structure is the document located? Make sure that the Url to the site, doclib and folders and file are not longer than 256 characters.

  • The full path to the document is "\\moss-cor\docs\documentation\Donations Policy.docx", so it's short enough. Other documents with longer filenames copy without error. Oct 14, 2009 at 9:07

Try renaming the file in the SharePoint UI then go back to Explorer view and retry.

Let me know how it goes.

PS. Are you an admin/SC admin? Do you have permissions to this item?

  • Nope, renaming did not help. I'm a SC admin, but the user getting the similar error on XP is not. I definitely have permissions. Oct 14, 2009 at 3:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.