1

Sometime after the 27th of last month sharepoint designer no longer lets me connect to SPO. It prompts me for my login and password, type it in and prompts it again. I installed SPD on another computer and same thing happens.

  • Check with your Admins and see if your permissions have changed. – lazoDev Jan 15 '19 at 17:51
  • I am the admin. If I look under permissions I have full control. Perns>site Collection Admins> My name is listed – user80879 Jan 15 '19 at 18:13
3

I just had the exact same issue, when working from home last week. It was due to a setting in Azure that the global admin had set, and we had not fully tested: disable access for apps that do not use modern authentication.

Usually when I leave the office each evening, I sleep my pc, not shut down. I was inadvertently avoiding a token refresh which would have made the issue arise for SPD and InfoPath. Neither use the relevant ‘Modern Authentication’ contemplated by the above mentioned setting.

| improve this answer | |
  • 1
    This setting also affect authentication using .NET CSOM. new SharePointOnlineCredentials(username, password) stops working and ends with an error Access denied. Before opening files in this location, you must first browse to the web site and select the option to login automatically. – Lukas Nespor Jan 16 '19 at 7:46
1
  1. Check if your site has this setting enabled

enter image description here

  1. Try to open the site from scratch unlike from recent sites
  2. try to clear the cache and here is the process to do it

. Close SharePoint Desginer2013.

. Delete everything from %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache.

. Delete everything from %APPDATA%\Microsoft\Web Server Extensions\Cache.

| improve this answer | |
0

Open your Office 365 Admin Portal->Select SharePoint from left navigation-> On SharePoint admin page, select 'Settings'->Check 'Allow users to run custom scripts on personal sites and self-service created sites', as shown below. enter image description here

Note: It takes about 24 hours for the changes to take effect.

Reference:

https://social.technet.microsoft.com/wiki/contents/articles/37533.sharepoint-online-how-to-enable-custom-script.aspx

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.