1

To be able to run the BackUp-SPFarm i need to create a network location/drive and grant the sql service account read/write permission. but for our sharepoint on-premises 2013 /2016, how i can know what is the SQL Server service account for our sharepoint servers, as some of these servers were created many years ago by other companies? now when i try to do BackUp-SPFarm it always fail unless i grant Everyone read/write. but i do not want to grant everyone access to the backup folders, where i only want to grant the sharepoint farm account (i can get this account under the security >> managed accounts), but i am not sure from where i can know what is the sql service account for our sharepoint farm? Thanks

  • 1
    You can refer below link and check the service account to know which account is used as SQL Server Service account. docs.microsoft.com/en-us/sharepoint/… – Divya Sharma Jan 10 at 11:57
  • @DivyaSharma in our case i can not find any accounts that start with MSSQL or sqlagent as described inside the link you provide – SharePoint TestDev Jan 10 at 12:10
1
  • Log in to SQL-Server via RemoteDesktop and start SQL Server Configuration Manager
  • Go to SQL Server Services
  • You will find a SQL Server (INSTANCENAME) service there. You might have multiple entries, please let me know if you need help identifying the correct instance
  • Column Log On As will show you the correct account.
    • SQL-Server by default gets installed with a virtual account like NT Service\MSSQLSERVER or NT Service\MSSQL$INSTANCENAME. In this case you need to give read&write permissions on the network share to the computer-account hosting SQL-Server
    • SQL-Server can be installed with a Domain-Account like DOMAIN\username. Give read&write permissions to this domain account on your network-share
  • thanks a lot for your help. i can do this inside one farm where i login to the sql server itself and i follow your steps and the Backup-SPfarm worked well. while on other farms i can not login remotely to the database server.. so can i from sharepoint server itself know the sql service account, or by running power-shell scripts or using Central admin? – SharePoint TestDev Jan 10 at 15:02
  • This is a SQL-Server specific setting. You cannot query it from SharePoint. If you have access to the SQL-Server via SQL Server Management Studio from any machine, you can query the required information via T-SQL: SELECT servicename, service_account FROM sys.dm_server_services – MHeld Jan 10 at 15:08
  • Now the backups working for You @SharePointTestDev ? So the SQL account needs to have permissions on backup folder? – Zdeněk Vinduška Jan 11 at 8:09
  • Yes. The Database Backups are placed directly by SQL Server to the Network Share. So it also needs proper permissions. – MHeld Jan 11 at 9:38
0

If you start BackUp-SPfarm it create a job, jobs are running under SPTimerv4 so look to Windows Services and Account which is used for SharePoint Timer V4, this account should have permissions to the Folder.

  • the sharepoint timer job runs under the sharepoint farm account, and this account is the owner of the backup folder... seems there are additional accounts that should have read/write on the backup folder – SharePoint TestDev Jan 10 at 12:11
  • have you mounted this folder to the SharePoint Application server or you are using UNC path? It'S this folder accessible from SP APP server? – Zdeněk Vinduška Jan 10 at 12:16
  • this folder is a local folder inside the sharepoint application server, and i have shared it. again if i grant everyone read/write the Backup-SPFarm will work well without any issues.. so there is not any problem with accessing the backup folder, also if i remove Everyone from the share settings, the backup folders will be created but their size will be less that 10 MB and the backup will have errors inside its logs... – SharePoint TestDev Jan 10 at 12:34
  • Have you tried add WPG_Admin group from APP server? – Zdeněk Vinduška Jan 10 at 12:36
  • what is exactly WPG_Admin ? – SharePoint TestDev Jan 10 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.