4

Until a few days ago, the "Open in Excel" function worked perfectly.

After installing version 1812 (Build 11126.20169) they are no longer able to open office documents from sharepoint. I receive the message:

Sorry, we could not open 'https: //subdomain.domain: 447 / Path / document.xlsx'

The portal uses an unconventional TCP port but this should not be the problem since with the previous office version everything worked smoothly.

On other sharepoint portals with a single authentication method, the opening of office documents also works regularly with version 1812.

Does anyone know what may have happened or has the same problem?

Thanks Leandro

  • Same issue here... the problem is related only to web applications with NTLM+Forms authentication – Maurizio Jan 10 at 8:46
  • Same issue here, with Word. Server is SharePoint Foundation 2013, patched to January 2019 cumulative update. Fiddler logs show that Word is making a POST request to /_vti_bin/cellstorage.svc/CellStorageService but is not including the FedAuth cookie in the request. – David James Jan 11 at 3:29
  • This thread proposes to downgrade. Anyone tried? – Codo Jan 15 at 7:51
1

Update to Office version 16.0.11126.20196 seems to have solved the problem.

  • Even though there's now a newer version available, we're also seeing that the problem has somehow been resovled for build 11126.20196 as well. – Codo Jan 17 at 7:11
1

A downgrade to an earlier version of Office helps:

  1. Open command prompt

  2. Type cd %programfiles%\Common Files\Microsoft Shared\ClickToRun

  3. Type officec2rclient.exe /update user updatetoversion=16.0.11029.20108

I don't fully understand that version number that needs to be specified. I used the Update history for Office 365 ProPlus page for help.

Update

There is a new version of Office available via the regular update channels that fixes the problem. It's still version 1812. The build number is 11126.20266.

We have also indication that the problem has been fixed for the earlier build 11126.20196. So it remains unclear how it has been fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.