Good Morning;

I am using Sharepoint 2013 OP with SPD2013.

I have made a custom form using SPD2013. I want to hide the "Spell check" icon at the top of the form. How do I do that?

  • Please explain more. How do you have created custom form? Where do you see the spell check option on form? Jan 8, 2019 at 18:17
  • I have created a custom form using SPD2013. I upload that as a Webpart to my site gallery. Using SPD2013 I created a new .ASPX page. I inserted a Web Part Zone then inserted the Form Web Part. I want to remove the Spell Check button at the top left corner. I also am having issues with my input fields aligning with the column names on the form.
    – Daryl
    Jan 8, 2019 at 18:34
  • Did you try using Java script to hide the element? Jan 8, 2019 at 22:35
  • I haven't been able to find one.
    – Daryl
    Jan 8, 2019 at 22:49
  • Are you talking about the "Spelling" option on form? given in the image: social.msdn.microsoft.com/Forums/getfile/798906 Jan 9, 2019 at 12:37

2 Answers 2


I would guess that you have the problem with the Spelling... link which shows up when you have a text editor on the page. If that's the case, you can remove it by using the following javascript:

var d = document.querySelectorAll(".ms-toolbar");
for(var v in d) if (d[v].style) d[v].style.display = "none";

Please check if there is anything else on the page with the class ms-toolbar and make the appropriate changes to exclude it if there is.


To hide the default Spell check option on SharePoint form, you can use either one of the below solution:

  1. Using Javascript: You can add the Script Editor web part on you form page and use below javascript code:

    <script type="text/javascript"> document.querySelector("li[id='Ribbon.ListForm.Edit.SpellCheck']").style.display = "none"; </script>

  2. Using CSS: You can add the Script Editor web part on you form page and use below CSS code:

    <style type="text/css"> #Ribbon\.ListForm\.Edit\.SpellCheck { display: none !important } </style>

  • I tried both of these and they don't work. Hmm
    – Daryl
    Jan 9, 2019 at 17:30
  • Can you share the screenshot by inspecting the spelling check element from browser's developer window? That will be helpful to answer your question. Jan 9, 2019 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.