0

I have added a couple of new columns to my SharePoint list. They show when I initially add them but when I return to the list later they are not displayed. They are there as I can see them in the List Settings view but not in the List View. Is there a limit to the number of columns displayed?

enter image description here

4

There is no such limit of showing number of columns in list view.

If newly added columns are not showing in your list view then you need to add those columns by changing the list view settings.

You can modify the view and select as much as columns you want show in list view.

Refer below article to read about list views in sharepoint:

Create, change, or delete a view of a list or library.

  • Thanks - found it. I am interested to know why these remained unticked when they were added and why all other columns created before were added as expected. – RGriffiths Jan 8 at 17:12
  • You may have unchecked the Add to default view option while creating new column. Or you are seeing this newly created columns in another views(other than default view). – Ganesh Sanap Jan 8 at 17:19
1

These columns are not enabled for that specific view. Please modify view and check whether desired columns are "checked in" (List settings -> Views -> [desired View] -> Columns). The fact that columns are showing in list settings does not mean, that they are selected to be displayed in the current view.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.