0

I am using the following breadcrum sample. To reproduce the error use command: gulp serve

Error I got:

./src/extensions/siteBreadcrumb/SiteBreadcrumbApplicationCustomizer.ts Module parse failed: C:\Users\username\Projets\26_name\Code\Breadcrumb\sp-dev-fx-extensions\samples\react-application-breadcrumb\src\extensions\siteBreadcrumb\SiteBreadcrumbApplicationCustomizer.ts Unexpected token (15:16) You may need an appropriate loader to handle this file type. | import { ISiteBreadcrumbProps } from './components/ISiteBreadcrumb'; | | const LOG_SOURCE: string = 'SiteBreadcrumbApplicationCustomizer'; | | /**`

  • Keshav , whether install npm to the solution works perfect? i would suggest create a application customizer by own and use their breadcrumb code this way i think there should not be any error. I have did for My favorites the same way. – vinit kumar Jan 8 at 8:21
  • @vinitkumar Yes npm install works correctly,when doing gulp serve that i get the error. – Keshav Taurah Jan 8 at 8:36
  • Can you run gulp serve-info and check ? – Gautam Sheth Jan 8 at 11:39
  • So, what's on line 15 of the SiteBreadcrumbApplicationCustomizer.ts file? – Derek Gusoff Jan 8 at 19:47
  • Can you provide more detail around the error - where did it happen, what lines of output were there immediately before the error? I've cloned the repo, run npm i and gulp serve-info --nobrowser here with no issues. What version of gulp do you have installed globally? What version of NodeJS and npm are you using? – Mike Insch Jan 10 at 17:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.