1

Im using Sharepoint Office 365 and I have custom workflows. I need the user to see only his workflow approval task on workflow.aspx page. But the workflow shows the name of all assigned to people as it assigns to the whole group (parallel and wait for 1st response only). How can I restrict the user to see only his name? Where are the settings? I can't access the workflow.aspx page for Sharepoint O365, this was restricted in on-premises 2013 by someone else and the client wants the same functionality on cloud as well. Thery are not willing to response through the Task List but they want to got through the workflow page.

enter image description here

User A,B,C sees the workflow tasks for each other. I want the user A to see only his name if he is logged in and similarly B and C.Any help will be appreciated.

0

You can create a SharePoint 2010 workflow on the Tasks list and design it like the below: enter image description here

And for the workflow start options, set it:
enter image description here

  • Thank you @Kally_MSFT. But it didnt work. It still shows the users the tasks for each other. Do I need to do anything before I create this workflow like register the app or something ? – Mehak Jan 4 at 16:09
  • Doesn't replace Full Control gives the users full control to item? How can other users are restricted to even viewing this item which are not Assigned To them ? here workflow is assigned to a group – Mehak Jan 4 at 17:02
  • After running the workflow, Replace Full control Permissions action will give the Assigned To user Full control on the current item, and other users will not see the current item. A thing you need to notice is that you need to use a user who has Full control on the site to create the workflow with SharePoint Designer. – Kally_MSFT Jan 7 at 8:47
0

enter image description here

@Kally_MSFT I tried the following and used the Workflow Start Options . But it didnot seem to work. Can you please suggest something else or am I missing something here?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.