1

I have a custom list and I have created some custom forms for this list in Designer. I also previously created a custom form in Infopath (using the "Customize Form" button on the ribbon), but I want to set the forms I created in Designer as the default. I already set them as the default forms in Designer, but I'm still getting the Infopath forms when I click on most new/edit/display links in the SharePoint list UI. I added the "Edit" column to my view, and clicking that will open my custom Edit form. But clicking New Item, View Item, or Edit Item in the ribbon all open the Infopath form. Clicking View Item or Edit item in the ellipsis menu also opens the Infopath form.

What am I missing? Is there a place in list settings to set your default forms? Is there another setting in Designer that I missed?

1

You should be able to change this if you go to List Settings -> Form Settings and check the "Use the default SharePoint form" radio button.

I've just tried it on the list in SP Online and it works fine.

EDIT (based on the comment from the OP):

In case you get the error "Internet Explorer is required to use this feature." even if you are using the latest Internet Explorer, you can solve it by pressing F12 in the browser and changing the Compatibility mode to IE 10. After that, the page should reload and you should be able to see the mentioned radio button option ("Use the default SharePoint form").

  • 1
    Thanks for the suggestion. Unfortunately, on the SharePoint servers that I'm working on (2013 btw), whenever I go to List Settings -> Form Settings I get a page that says "Internet Explorer is required to use this feature." Which is odd, because I'm using Internet Explorer. But I found a workaround in Designer. See the answer that I posted for the details. – Jason Jan 2 at 19:06
  • 1
    That compatibility mode change fixed that issue. Thanks! – Jason Jan 2 at 19:27
0

I was able to fix this by checking the "Allow management of content types" box, and then editing the "Item" content type that I'm using for this list. In Designer, I clicked on the "Item" content type, and then edited the names for the forms used for this content type in the "Forms" section of the content type page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.