1

On SharePoint 2013, we are having issues with properties on users profiles. For example, there are users who changed job title but this change is not depicted in the user profile.

The type of synchronisation is AD import and every 5 minutes an incremental synchronisation is performed. Before ending up with a full sync I am looking into potential workarounds.

Initially I deleted the MySite of a user and let the user login afterwards to recreate the site but it didn't work. The properties had still the same old values.

The second thing I tried, was to delete the user profile but I failed. I assume because of inadequate permissions:
enter image description here

How can I get the proper permissions to delete a user profile (I am already a farm admin)?

Is there any other workaround to update the user profile properties that are not being synchronised without running a full synchronisation?

1

To delete a User Profile you need to be a User Profile Service admin. In Manage Service Application select the User Profile Service Application (Don't click the link, just select the line.) and then choose Permissions and give yourself Full Control.

Deleting the MySite has no impact on the User Profile. It just deletes the User's Content. The User Profile is stored separately in the UPS Profile Database.

In order for incremental User Profile Synchronization imports to work the Service Account running the Synchronization must have the proper permissions in Active Directory. I suspect this is the root of your problem. Recheck the documentation and ensure that your AD folks followed the guide EXACTLY. The important bit is this and most folks don't know how to do it.

The synchronization account must have Replicate Directory permissions or higher on the root OU of AD DS.

  • Thanks for the reply. As you suggested, in the User Profile Service, not only I gave myself Full Control under Permissions but also added my account in the administrators group of the service including all the permissions. I am still getting the same error though. Should I have any special permissions from the database perspective? – dimitrisd Dec 28 '18 at 12:11
  • Those permissions should resolve your inability to delete a profile. Through the UI. The crawl problem is a separate issue issue. – Matthew McDermott Dec 28 '18 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.