0

I'm having an issue, where SharePoint designer is not able to connect to my sharepoint site, I'm given the below message:

enter image description here

I googled this issue and found topics highlighting the below points:

  • New Relic agent problem

    My finding, no New Relic agent is installed on the servers.

  • Issue with Security Token Service Application

    My finding, the security token service application is up and running, and it's browsable, it opens without any issues.

Sometimes, SharePoint designer is trying to connect to the site, in the "open site "dialog, the site name is something like this "DavWWWRoot (\site.domain.com)" , but then when I click Open, I'm given nearly the very same message above.

Any idea? Much appreciated.

  • Try clearing the cache of the designer. You can refer the below link on how to stackoverflow.com/questions/43113666/…. – Ashik Paul M Dec 26 '18 at 9:00
  • Thank you for your response, I tried cleaning the cache of the deisgner way before, but it's the same thing. – Mohammad Akilan Dec 26 '18 at 9:02
  • Try steps mentioned in this blog...susheeldakoju.com/?p=998 – Hardik Dec 26 '18 at 12:40
  • Thanks, but as I've already mentioned in my post, there's no New Relic agent installed. – Mohammad Akilan Dec 26 '18 at 12:42
  • Do you have this issue when opening other sites with SharePoint Designer? If other sites also have this issue, you may need to check event log to find more information about this issue. – Kally_MSFT Dec 27 '18 at 3:23
0

I had the same issue earlier.

Restarting the server would solve the problem but since we are concerned about specific site opening from SP Designer, so just restart that site in IIS.

Edit:

The issue seems to be in a .NET Agent installed by NewRelic on the server. This agent is used to analyse traffic, page load time and some other cool things. It basicly add some javascript to the head session of every response our IIS make and this code send some data to New Relic servers that will be processed to build some reports about the applications running in the IIS.

You can disable RUM by editing newrelic.config and changing this line:

<browserMonitoring autoInstrument="true"/>

to this:

<browserMonitoring autoInstrument="false"/>

References: MSDN Technet

  • I've restarted the servers with no hope, performed IIS reset and it did not work. – Mohammad Akilan Dec 26 '18 at 12:45
  • @MohammadAkilan I have updated the answer. Please refer! – Sohail Shaikh Dec 27 '18 at 6:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.