0

I have a list which is set so only the creator of the item can see and edit their own items (so that others cannot see personal information collected). I have created a SP2010 based workflow in SP Designer 2013 with an impersonation step (run from a service account) which grants a named manager (specified by the item creator) "edit" access to the item. However, despite the item showing the permission has been set, they cannot open the item sent to them via the workflow. The error states "no item exists, it may have been deleted or renamed by another user". I have tried giving higher permissions to the manager to enable this to work but still get the same error message. The link they are being sent is a bespoke edit link built in SP Designer giving them a view of only the columns they need to see. I have also tried sending them the default edit and display views to no avail. Help would be appreciated.

0

To override the item-level permissions, you need to have at least 'Design' permission level.

Try granting that for your manager and it should work.

  • thank you but I have already tried that, I even gave them "complete control" on the item. they still can't open it let alone edit it. Any other thoughts? – Brightspark Dec 24 '18 at 12:22
0

It’s the default behavior that if we configure item-level permission in list settings, even though we have permission to edit the items, we are not able to see the items.

To work around this behavior, we can create a custom permission level via site settings->site permissions->Permission levels->click “Edit”->copy permission level and tick additional permission as below:

enter image description here

However, we need to assign custom permission level in the list level so that users can override the list behavior.

0

Just in case anyone reads this, I have got this working. 1. Create the list with access to create new item to ALL users who need to input to the list 2. Set the default view to items only created by "me" 3. Change the all items permissions view by doing the following Open Allitems.aspx • Edit page • Edit webpart • Advanced • Target audiences Set to the group who needs access to the whole list (ie your HR team) 4. Set the list to not be indexed - just to be on the safe side 5. Create workflow (I used SP2010 workflow) • Impersonation step 1 - Give named manager from a list column “contribute” • Impersonation step 2 - Give creator “contribute” (you could give read if you don't want them to edit the item again) • Impersonation Step 3 - Remove read, edit and contribute from the group with original create access (this has to be last otherwise the workflow will not action) Make sure the account used to create the workflow is not a personal account

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.