1

Could just be Friday brain, but I'm not having any luck tracking down a potential cause or fix for this issue. I have a document library in my SharePoint 2013 server farm which has been behaving normally. It's a Document Center with some custom columns but everything's out of the box.

Today a user reported that a single file in this document library is returning "Something went wrong" when attempting to view Version History. I pulled the logs and they revealed:

Application error when access /_layouts/15/Versions.aspx, Error=Value cannot be null. Parameter name: termId at Microsoft.SharePoint.Taxonomy.Internal.CommonUtilities.ConfirmNotNull(Guid value, String parameterName) at Microsoft.SharePoint.Taxonomy.TermStore.GetTerm(Guid termId) at Microsoft.SharePoint.Taxonomy.TaxonomyField.TryGetWssIdsOfTerm(SPSite site, TermStore termStore, Guid termSet, Guid term, Int32 limit, List`1& itemIds) at Microsoft.SharePoint.Taxonomy.TaxonomyField.GetGuidOfWssId(SPSite site, Guid sspId, Int32 id, String& termId) at Microsoft.SharePoint.Taxonomy.TaxonomyFieldValue.get_TermGuid() at Microsoft.SharePoint.Taxonomy.TaxonomyFieldValue.ToString() at Microsoft.SharePoint.Taxonomy.TaxonomyFieldValueCollection.ToString() at ASP._layouts_15...

I've confirmed that Version History still works for other documents in this library, as well as downloaded and re-uploaded the file fresh and Version History worked then as well. My gut says it could just be a corrupted file, but I hate defaulting to that answer so I figured I'd check here before giving up.

Any ideas?

  • 1
    Is there are any metadata fields associated with this library? Are these fields are mandatory? And check the properties of this document file and confirm that all the required metdada fields are filled properly. – Ganesh Sanap Dec 22 '18 at 2:55
  • what permission did the user have on the document? Could other users view version history of the document? – Kally_MSFT Dec 24 '18 at 8:48
  • @GaneshSanap - Some metadata is required but most is optional. All fields are properly filled in and the document otherwise functions normally in areas where bad metadata would cause issues (allowing check in, for example). When I reuploaded the same file with the same metadata in my troubleshooting everything worked. – Brendan W Dec 24 '18 at 20:54
  • @Kally_MSFT - It has been tested and error behavior replicated by users with farm admin, site collection administrator, and local Full Control admin access. – Brendan W Dec 24 '18 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.