I have been given the task to place a link on a sharepoint page that has been develped by someone else. I have full control permission in the site.When I try to edit the page all options are grayed out in the web page ribbon. The edit file option is disabled in sharepoint designer. What should I do?

When I do Save & Close after Edit Page in the browser. I get the following error:-

Server Error in '/' Application.

Object reference not set to an instance of an object. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.] Microsoft.SharePoint.Publishing.Internal.WebControls.PublishingPageStateControl.RaisePostBackEventForPageRouting(String eventArgument, SPRibbonCommandHandler control, RaisePostBackEventDelegate raisePostBackEventDelegate) +175 Microsoft.SharePoint.Publishing.Internal.WebControls.PublishingPageSaveAndStopEditHandler.RaisePostBackEvent(String eventArgument) +133 System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +28 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2980

2 Answers 2


Assuming that you have full permission to edit the file, right click on the file in SharePoint Designer and choose "Edit File in Advanced Mode". This will allow you to edit the page's HTML and ASPX content and save it.


  • When I Edit File in Advanced Mode I am able to view its contents and I can do any change but when I try to save I get this error:- The URL 'Pages\mypage.aspx' is invalid. It may refer to a nonexistent file or folder, or refer to a valid file or folder that is not in the current Web.
    – user558138
    Commented Dec 6, 2011 at 14:50
  • This means your log is full, which is why you are not able to edit or add anything. Put your log file settings to simple and then shrink it, that should resolve the issue. Your log file is located in c:\program files\common files\microsoft shared\web server extensions\14\logs.
    – DigiOz Multimedia
    Commented Dec 6, 2011 at 14:54
  • The folder you have mentioned has a lot of files. How do I put log file settings to simple? And how to shrink it?
    – user558138
    Commented Dec 6, 2011 at 15:01
  • Sort the files in the "Logs" directory by date modified. You can go ahead and delete any files that are more then a day old. You can also adjust how many logs get created in Central Admin under Diagnostic Logging section.
    – DigiOz Multimedia
    Commented Dec 6, 2011 at 15:11
  • Did the above steps, still getting the same error! I have added some more details related to the problem in the question. Please check.
    – user558138
    Commented Dec 6, 2011 at 15:21

The web page is probably a publishing page and it is checked out to an other user. You will need to have it checked it in before modifying.

  • I am able to checkout/checkin the page from sharepoint designer. Still unable to edit it.
    – user558138
    Commented Dec 6, 2011 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.