3

I have one custom list with Yes/No type field in our SharePoint site(tried both on 2013 and 2016 on premise).

I did below steps:

  1. Created one page.
  2. Added OOTB SharePoint List Filter web part on Yes/No type field.
  3. Added List web part of the same list.
  4. Connected this web part with same field on List web Part.

And When I tried to filter the data in List web part by selecting Yes or No choice from filter dropdown, For both choices it is showing me the items with value "No" selected only.

Is it a bug or is there something I am missing to configure to get it working??

Thanks for your help!

2
  • I'm also getting the same output as you get, might be a bug. Dec 21, 2018 at 7:35
  • Yes, you can use "Choice Filter" or "HTML Form Web Part" by adding Dropdown as a work around for this. Dec 21, 2018 at 13:42

1 Answer 1

2

It is a known issue. The Yes/No value is 1 or 0.

It can not be compare to boolean type true/false or string type Yes/No.

You can use a Choice Filter instead, like given below:

enter image description here

2
  • Thank you. Adding to your answer, we don't need to provide (empty) as choice. we can add it from "Advanced Filter Options" in web part properties. Dec 21, 2018 at 7:56
  • Also, we can use "HTMl Form Web Part" with some HTML Coding (By adding Dropdown with values 1 and 0). Dec 21, 2018 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.